1

I've just upgraded from ExpressionEngine 1 to 2. The upgrade ran smoothly and I can access my admin panel. Whenever anyone goes to the site, they're greeted with this error:

A PHP Error was encountered

Severity: Notice

Message: Channel::parse_related_entries() [channel.parse-related-entries]: The script tried >to execute a method or access a property of an incomplete object. Please ensure that the >class definition "DB_Cache" of the object you are trying to operate on was loaded before >unserialize() gets called or provide a __autoload() function to load the class definition

Filename: channel/mod.channel.php

Line Number: 448

Fatal error: Channel::parse_channel_entries() [entries'>channel.parse-channel-entries]: The script tried to execute a method or access >a property of an incomplete object. Please ensure that the class definition >"DB_Cache" of the object you are trying to operate on was loaded before >unserialize() gets called or provide a __autoload() function to load the class definition >in .../system/expressionengine/modules/channel/mod.channel.php on >line 3686

Does anybody have a clue what I need to do to bring my site back online? Help greatly appreciated.

Update: I have tried to rebuild a template step-by-step and have identified that the problem is when I close the {exp:channel:entries} tag. Does anybody know what might be causing this?

  • Have you double checked your file permissions? – AllInOne Mar 10 '14 at 19:42
1

Could it be that one of add-ons you have is using Channel::parse_related_entries()?

You might want to check that. Otherwise it looks like some relationship field did not upgrade correctly.

| improve this answer | |
  • 1
    I had a similar issue and it was a result of reverse related entries not being the correct syntax after the upgrade. – Justin Long May 10 '14 at 22:30
0

Best bet would be to talk to your hosting provider it looks like you may need a different version of PHP

| improve this answer | |
  • Thanks Jez, the system requirements are 5.2.8 or higher, my host is running 5.3. Do you think it requires upgrading to 5.4? The host seem to think it should be okay as it is. – beardymouse Mar 10 '14 at 18:19
  • aaah probably not then - it looks like it is more of a template problem linked to 'related entries'. Maybe you have some relationship fields in your custom fields that didn't upgrade correctly to 2.x? – Jez Swinscoe Mar 10 '14 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.