1

Since updating to WYGWAM 3.3 the ability to increase indent on text stopped functioning on standard paragraphs (ol and ul does work). Worse anything I had indented using this way has lost the styling for indents. I've looked at the configuration area but can't find anything that would cause this.

Any help would be greatly appreciated.

5

I was able to fix this by adding back in the indent block plugin from CKEditor. The process of doing so is as follows...

  1. Download the CKEditor Indent Block Plugin. Make sure to download the version that matches the version of CKEditor being used by WYGWAM. Check the WYGWAM changelog if you're not sure.
  2. Unzip and install that folder to themes/third_party/wygwam/lib/ckeditor/plugins/
  3. In the Control Panel, go to Add-ons -> Modules -> Wygwam.
  4. Select the editor configuration you want to have this added to.
  5. For the Dropdown "Add an advanced setting" choose "extraPlugins."
  6. Paste "indentblock" without quotes into the field provided and click update.
  7. Repeat 4 through 6 for any other editor configurations as needed.

Fair warning, you will need to add this plugin every time you perform a WYGWAM update. Ideally this originally standard feature will be added back in for a future release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.