1

Freeform: 4.1.2 EE 2.7.0

Trying to upload a file with an entry. So far no success.

I referenced this post

Here is my code:

{exp:freeform:form
   form_id="1"
   required="name|email|phone1|experience"
   return="page/thank-you"
   notify_admin="yes"
   notify_admin_template="contact"
   file_upload="Resume Uploads"
   send_attachment="yes"  
}

I tried this for the input field - it looks right but does not upload the file.

<input type="file"{freeform:field:file1 show="1"}

So I tried this and it simply creates a text area with no file upload options.

{freeform:field:file1 show="1"}

I have searched the Solspace documentation, but there are no examples and the file upload code does not help.

I would appreciate any assistance on this.

Thanks.

1

In my template, the field looks like this: {freeform:field:attach_your_resume}

First, I would try removing the part of your tag that says "show=1" and just use: {freeform:field:file1}

Second, did you create the field called "file1" (from the freeform admin inside EE) And if so, what filetypes did you set it up to accept?

Also, in Expression Engine, have you set it up to allow those kinds of file uploads? Look in: Content->Files->File Upload Preferences and look at the Allowed File Types for your file upload location.

Then, if that still isn't working, you may need to look at your mimes.php file which is found inside the Expression Engine core.

| improve this answer | |
  • Enga, you were spot on. Thank you for the tips. – forrest Mar 21 '14 at 17:57
  • great! I'm glad it worked! – enga Mar 21 '14 at 17:57
  • 1
    Also worth mentioning that file_upload="" and send_attachment="yes" are not valid parameters in {exp:freeform:form}. Parameters are listed here: solspace.com/docs/freeform/form/#parameters – Solspace Mar 22 '14 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.