2

I'm using Freeform 4.1.4 (the free version) w/ EE 2.8.1.

I have a form with a first name field ({name_first}), a last name field ({name_last}), and an email field ({email}) field, all of which are required. When I created the form's notification, I configured the "From Name" field to use "{name_first} {name_last}" and "From Email" to use "{email}".

In the past, this has always worked: the email notifications used the user-submitted values for the sender info.

However, on this site, the email notifications arrive but they come from "unknown sender" (according to Gmail). Everything else about the notifications is fine -- e.g., the message comes through intact -- but the sender info is missing.

On a whim, I tried hardcoding the notification's "From Name" and "From Email" fields so they weren't using user-submitted values, but that didn't fix anything. And I've checked the EE installation's email settings, which are the defaults (AFAIK). Nothing seems out of the ordinary there.

Am I missing something? Did something change in notifications with the new version of Freeform?

  • FWIW, I've updated to Freeform 4.1.5 and the problem still persists. – Jason Morehead Mar 25 '14 at 17:21
2

This is a bug in Freeform 4.1.4 and 4.1.5. This will be fixed in Freeform 4.1.6 which we are working on now.

If you'd like to patch it yourself in the meantime, in:

./system/expressionengine/third_party/freeform/libraries/Freeform_notifications.php

around line 484, change:

$this->variables['from_email']      = $from_name;

to:

$this->variables['from_email']      = $from_email;
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.