0

I get this error when trying to do anything with modules or extensions. I'm currently deleting each ones presence from the db and filesystem, but i really don't want to drop freeform_pro.

Any ideas on what i can do besides delete files?

A PHP Error was encountered

Severity: Notice

Message: Undefined index: C

Filename: addons/Addons_installer.php

Line Number: 501

0

Always make a backup of database and the directory. Store them in a zip file. Get the backup running and working on a local development environment, and make another backup of this working copy. This way you can always return to a known working copy.

If any of the crucial modules don't work, then verify the add-on compatibility, but you will be able to keep the production website running on the version that works.

To temporary disable all extensions in 2.8, use the
hidden config variable $config['allow_extensions'] = 'y';
and uninstall the offending extension for the time being.

When a new version of the add-on becomes available,
repeat the process (of setting up a local working version)
but prior to updating EE, first update the add-on for a smooth transition.

Troubleshooting on a lower level, does require knowledge of PHP and the system.

| improve this answer | |
  • I had a WSOD when i removed 'tag-solpace' from my addons folder. I'm thinking i had a corrupted db-backup. I may have to start fresh. – Matt Mar 30 '14 at 13:27
  • I ended up going back to 2.8.1 and slowly introducing the addons back into the folder and i discovered the issue. Thanks – Matt Mar 30 '14 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.