2

Is it possible that there's some kind of issue for anyone upgrading from EE 2.5.2 to 2.8.1? I've tried it several times now, and what happens is the process starts and initially takes EE to 2.5.5, then stops at 2.6.1. The main admin.php file is then stuck on the welcoming upgrade screen, even when deleting the /installer directory.

  • When I've come across similar issues it's been down to the contents of config.php. Check what $config['app_version'] = ''; is set to. – Ian Apr 12 '14 at 14:42
2

When I've come across similar issues it's been down to the contents of config.php. Check what $config['app_version'] = ''; is set to. It should match the version of EE that is currently installed when you run the installer (2.5.2 in your case). When it's been set to a different version (sometimes because the config files has been copied across from another installation when setting things up on the new site) I've seen the errors you describe.

Unfortunately they've not been easy to fix once you start getting into that situation as the installer and the current installation start getting confused. In those cases I've found it easier to restore from a backup, double check the settings, and then proceed with the upgrade.

I don't think there should be any particular problem with the upgrade proceedure from 2.5.2 to 2.8.1 however.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.