0

I've just started to install expression engine 2.8.1 (for the record I experienced the exact same problem with version 2.7.3) I've installed expression engine god knows how many times and have 6 copies of expression engine on the same server but when I go to run the installer I am experiencing the error

Unable to locate the specified class: Security.php

Has anyone experienced this before and if so, what was the fix?

Thanks

3

After a little research and a bit of asking around on forums, I found that GoDaddy shared servers were reading the contents of the Security.php file and treating it as malware.

I've got in touch with GoDaddy and I'm waiting on a response but this is another reason for me to take my hosting elsewhere...

http://ellislab.com/forums/viewthread/244598/

1
  • 3
    Yeah, apparently GoDaddy is attempting to detect malware by doing some keyword scans, but it appears to only be when uploading files via FTP. Happens with WordPress too or really any file with certain words in it. One solution mentioned in the forum is to create the file via GoDaddy's cPanel. – Derek Jones May 8 '14 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.