I recently migrated our sites over to Nexcess EE hosting. After that I notice that some images are not showing up. Some images in certain directories work as expected, while others in the very same directory do not. Upon further investigation in the source the image paths read the following:


We are expecting to see:


Has anyone seen this? What is a possible remedy?

  • Need more info I think. What is the EE code that results in this? First guess is that there is a site preference not set properly. Do you have a value for Admin > General Config > URL to the root directory of your site ? What result are you expecting here? /chrootimages/uploads/image.png ? or something else?
    – AllInOne
    Commented Dec 26, 2012 at 17:08
  • [edited] The problem with Ad Man was unrelated. Commented Dec 28, 2012 at 19:59

4 Answers 4


So it was an issue with CE-Image and the paths it uses to find images. Since we moved directories it was looking for some images in the old location and the rest in the current which is why the fact that some worked was somewhat perplexing.

Added this config setting to our bootstrap and we are looking good.

$config['ce_image_src_regex'] = array( $images_url . '/' => $images_path . '/' );
  • 1
    should in future mention that you're using something like CE Image as well ;-) Commented Dec 28, 2012 at 22:04
  • 1
    Indeed. I should have but I didn't even think it could be the issue (at the time). Until I read about how CE Image actually works :) Thanks for the help and getting me to dig into it! Commented Dec 28, 2012 at 22:35
  • 1
    As stated by Kara Todd, an easier way to accomplish this is to use the: $config['ce_image_document_root'] = '/some/server/path/to/document_root/'; setting. It appears the document root that is set for the server is not pointing to the correct web root path for some reason (I bet Nexcess would be happy to correct that for you). The ce_image_src_regex solution is basically a workaround to accomplish the same thing. It works, but setting the correct document root is favorable, in my opinion, since a regular expression doesn't need to be run for each image path (and because it is simpler). Commented Feb 3, 2013 at 18:40

I had this issue as well, but for me it turned out be a misconfigured server "base path" issue. Which is explained in the CE Image Common Solutions docs. Setting the config variable in my (NSM) config bootstrap file solved the issue for me:

'ce_image_document_root' => NSM_BASEPATH

or as stated on the solutions page:

$config['ce_image_document_root'] = '/some/server/path/to/document_root/';

I would look at your image paths Content > Files > File Upload Prefs and make sure that your image directories have the appropriate paths.

It's a good idea to bootstrap your config for upload directories so that they work regardless of what server you're on.

  • I also highly recommend you bootstrap your config and add the file upload override settings for each of your upload directories. It'll save you a ton of time and headaches as you deploy to multiple environments. See the file upload override settings here for reference: ellislab.com/expressionengine/user-guide/cp/content/files/… Commented Dec 27, 2012 at 0:10
  • Upload prefs are bootstrapped already. All paths are correct in the control panel. Commented Dec 28, 2012 at 18:35
  • All images also appear as expected in the CP file manager, just a few images have " /chrootimages" rather than the full path as explained in original post. Commented Dec 28, 2012 at 18:41
  • Seems to be an issue with CE image not parsing the {made} path correctly. See if I can figure that out. Commented Dec 28, 2012 at 18:51

I had a similar problem with CE Images -- some images working and others not after migrating to a remote Linux server. I turned on Template Debugging and found that the /~user segment of my temporary URL was messing things up. Causing Effect has the answer to this problem in their CE Image user docs here: http://www.causingeffect.com/software/expressionengine/ce-image/user-guide/common-solutions#base_path. Adding the additional lines to the config.php file fixed the base path issue for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.