1

I'm having a problem with checkboxes displaying above their label when using {freeform:field:FIELD_NAME} for checkbox_group field types.

I've tried applying classes by using attr:NAME as well as wrapper_open/close and row_wrapper_open/close options, but nothing is working.

Is there some way to make my checkboxes display inline with their labels that I'm overlooking?

1

It sounds like all you need to do is apply display: inline; to both your label and input elements. Those elements are inline by default, so is it possible that you're setting them to block somewhere else in your stylesheet? Also, check your markup output in Developer Tools or Firebug; are your label and input wrapped in a block-level element?

For me, I did something like this:

{if composer:field_type == 'checkbox_group'}
    {freeform:field:{composer:field_name}
        attr:class="control--checkbox-group"
        wrapper_open="<div>"
        wrapper_close="</div>"
        row_wrapper_open="<div>"
        row_wrapper_close="</div>"
        input_wrapper_open=""
        input_wrapper_close=""
    }
{/if}

The markup looks like this: http://cl.ly/image/1w1o1f1P1X2N; and then I used the class control--checkbox-group to style and format the controls.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.