2

Does someone already used the AngularJS routing inside EE templates?

Inside common html template the AngularJS routing is working fine, but inside EE templates the routing is not working. What could be the problem?? An .htaccess setting??

thanks,

Stéphane

8
  • 1
    Can you give more detail about what "not working" means? Any errors? Can you see what EE URLs are being hit via the browser dev tools? Apr 14 '14 at 1:19
  • Hi Jeremy! no errors, the segment is not routed inside an EE template, no results, a blank page. And the AngularJs routing it's working fine inside a basic html page with no EE templates. I am a newbie to AngularJS, more practice will help me :)
    – Stéphane
    Apr 18 '14 at 17:12
  • Did you manage to work it out? Maybe I can help you out? Apr 28 '15 at 20:48
  • Hi jShadow. Thanks for your reply. If i didn't manage it, but if I need your help, it would be a pleasure!
    – Stéphane
    Apr 29 '15 at 1:14
  • 1
    I bypass Expression Engine routing all together. I have 1 template in my main.group called index.html. In this I have some ee embeds for the header and footer and my ui-view div (yes, I use ui-router). Besides the main.group I created a group called api.group. In this group I create templates that output JSON (in combination with the json addon by Rob Sanchez). So getting the data is a breeze! AngularJS retrieves it's data by calling the api.group's template url and it returns JSON so Angular can process the data in it's templates. It works like a charm! Apr 29 '15 at 8:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.