2

THE PROBLEM:

  • When editing a template file via the control panel, saving it with "save template as text file" ticked gives the error: "Unable to save your template as a text file"
  • The template is updated in the database, but not saved out to a file
  • Although the template is saved to the DB it does not reflect any changes on the actual site

SERVER CONFIGURATION:

Design --> Templates --> Global Preferences:

  • Save Templates as Files: Yes
  • Server path to site's templates: /var/www/vhosts/serverxxx-xxx-xx-xxx.live-servers.net/hbr-new-website/system/expressionengine/templates (I have tried this with/without trailing slash)

Permissions:

  • /system/expressionengine/templates and all subfolders and files set as 777

PHP settings:

  • Safe mode: off
  • open_basedir: /var/www/vhosts/serverxxx-xxx-xx-xxx.live-servers.net/hbr-new-website/:/tmp/
  • $_SERVER["DOCUMENT_ROOT"]: /var/www/vhosts/serverxxx-xxx-xx-xxx.live-servers.net/hbr-new-website

Any ideas? I'm absolutely stumped :-(

  • Do you have this with all of your templates, or just with one? If just for one, check if the settings for that file are correct. – Hansl Apr 17 '14 at 14:33
  • 2
    Check if you have ownership of the files. YOur host may need to change the ownership on that folder and contents. – CreateSean Apr 17 '14 at 14:50
  • @Hansl I have it with all my templates. – Jack Apr 22 '14 at 17:00
  • @CreateSean I've checked ownership just now. PHP is running as apache. I have set both User and Group to apache with 777 in place. IT STILL FAILS! :-( I'm at my wits end... – Jack Apr 22 '14 at 17:13
1

Whenever I encounter this issue, I always find it's either because of permissions or the path. If your permissions are all fine, you might double-check the path with the host, just to make sure. Doing so has cleared up this problem for me in the past (even when it seemed the path was correct).

| improve this answer | |
0

I had problems with this also. For me it helped to create the group-folders manually. That means: If you create a template-group named "embedMe" EE will create a folder embedMe.group. Delete this folder and create it manually (certainly with 777). For me this solved the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.