1

I don't know what is the problem, I'm updating EE2.7.3 using the EE documentation upgrading, and when I go in the admin panel do update: admin.php i got a blank page with this url:

http://myurl.com/admin.php?C=wizard&M=license&language=english

config.php and database.php are setted to 666, tried with 777 to.

when i did the update on the wamp local installation, no problems occured.

thanks,

Stéphane

2
  • Do you get a blank page straight away or after trying to update? Do you use a bootstrap of some kind or just the regular config.php/database.php that EE generated at the onset?
    – notacouch
    Apr 23 '14 at 18:06
  • thanks for your reply. The update is not effective, just after the message: Did you perform a full backup of your existing ExpressionEngine files and database? appears the blank page with admin.php?C=wizard&M=license&language=english. I'm not using bootstrapof some kind or just the regular config.php/database.php. Strange, this problem never occured before.
    – Stéphane
    Apr 23 '14 at 18:40
0

Personally I've been using a custom bootstrap which in the past caused a lot of issues when updating. I fixed this by keeping a copy of the config.php and database.php that EE itself generates upon install/upgrades and using those when upgrading. But before that I would get different types of errors including a blank page after trying to update.

What I did to troubleshoot that was go through the update files and see what EE was trying to do, e.g. add or alter tables in the database, and see which of those were completed.

It generally got stuck in between versions so I would manually update the version in the config and it would pick up from there.

You could probably try those same steps, look at what the upgrade is trying to accomplish and see where it succeeded, where it hung up, etc.

3
  • From EE2.7.3 to EE2.8.1 the database is upgraded too?? If not I will set manually the config.php.
    – Stéphane
    Apr 23 '14 at 19:06
  • 1
    Yes, I just looked in system/installer/updates folder. I presume the wizard would run through ud_280.php and ud_281.php. If you can read through the code and compare/contrast with your database (if you use some kind of interface like phpmyadmin) you can figure out which updates were/weren't done. Btw I hope you did back up your database beforehand! Running a diff before/after might help.
    – notacouch
    Apr 23 '14 at 19:11
  • Thanks for you tips... I tried many times with no results. Modify the Dabatase, too many work and risky. Fortunately, i've found a old EE 2.7.1 config.php. I've just changed 271 to 273 to the app_version. I cleaned the database too, because some modules have been removed and the modules tables in the database was not removed. It's working fine.
    – Stéphane
    Apr 23 '14 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.