0

I just upgraded a site from EE 2.5.5 to 2.8.1 and I get this error after I try to login:

Unable to load the requested class: services_json

I have searched and found reference to Zoo Members and Field Editor, neither of which I have on this site.

I did some additional searching and found a file in Expressionengine/libraries/services_json.php in the 2.5.5 install files that I backed up. However, I can't find anything that would reference this file. If I add the file I can log in but I get a white screen, without the file I get the error message. Either way I am toast.

Insight are most welcome.

Thanks.

2

I know this one was very obscure and thereby avoided by most readers, but in the event that anyone out there has the same experience, here is the solution.

There were several add-ons that reference /expressionengine/libraries/services_json.php in EE 2.5.5, including Freeform and devot:ee monitor. I had to update these modules to the latest releases BEFORE updating Expression Engine to 2.8.1, otherwise they were searching in vain for the services_json.php file.

After updating the modules, the upgrade went without a hitch.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.