2

I recently upgraded a local EE setup to 2.8.1 and now I cannot login to the CP. The page just refreshes.

I'm pretty sure that I've searched and read everything on EESE to find a fix but I'm still stuck. Here's what I've tried:

  • Clearing cache
  • Clearing cookies
  • Restarting Chrome
  • Also have used Incognito mode in Chrome
  • Deleting sessions in the DB (exp_sessions table)
  • Changing session types between cookies, sessions, and cookies + sessions

I'm using Focus Lab's Master Config and have this in my config.master.php file:

    // Session Preferences
$env_config['admin_session_type']       = 'c'; // cs|c|s
$env_config['user_session_type']        = 'c'; // cs|c|s
$env_config['cp_session_ttl']           = 86400;

// Cookie Settings
$env_config['cookie_domain']            = '.' . preg_replace('#^www\.(.+\.)#i', '$1', $_SERVER['HTTP_HOST']);
$env_config['cookie_path']              = '';
$env_config['cookie_prefix']            = ENV . '_'; 

Add-ons installed (in case it matters):

  • Draggable
  • Lovely Sorted Addons
  • Show Me My Assets
  • Single Entry
  • Snippet Sync
  • Stash
  • Superfish Admin
  • Custom System Messages
  • VZ Bad Behavior
  • VZ URL
  • Zoo Flexible Admin

[EDIT] I've also tried in Firefox and Safari; same thing.

Again, this is on my local setup and does not live anywhere else on the Interwebz. Everything was working before the upgrade to 2.8.1 (was previously on 2.7.2).

Help!

2

Try disabling extensions and turn on debugging. Could be a PHP error getting in the way of the login.

Also, I'd try the login in a browser you don't use often to eliminate a browser cookie issue. Chrome is not exactly good about letting go of cache I find.

| improve this answer | |
  • Ah, forgot to mention that I did try FF and Safari too. Will updated the original question, as well as try your suggestion. – Angie Herrera May 2 '14 at 18:27
  • Crud... disabled extensions and turned on debugging. No change. :( – Angie Herrera May 2 '14 at 18:32
  • AHA!! Finally got it working. $env_config['allow_extensions'] = 'y'; was in two spots: master config file and native config file. Once I changed the settings in both (and commented out one of them), it worked. – Angie Herrera May 2 '14 at 20:13
  • Tada! Good job tracking that down. – Anna_MediaGirl May 2 '14 at 21:01
0

What happens if you set $env_config['cookie_domain'] = the domain for your local setup manually?

| improve this answer | |
  • No change. Still can't login. :( – Angie Herrera May 2 '14 at 18:50
0

I just finished dealing with a similar issue... make sure you upgrade Zoo Flexible Admin to the latest version (v1.82+)

| improve this answer | |
0

I have another potential idea to throw into the pot. We've just experienced the same issue with Stash and Custom System Messages.

I've experienced similar issues on the frontend where an incorrect path to the stash embed on the custom system message template led to some sort of looping issue.

I would disable Custom System Messages and see if you're experiencing the same issue. If that is the case then you can check the assigned template for anything that may cause a problem.

To disable one extension, jump into the database find the extension (should be listed under the column class) and change the last row(s) to "n". As always, take a backup of your DB first.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.