2

This is an old issue that has resurfaced. I am creating entries using Profile:Edit and Relationships, that have address information and for some reason the first of the series displays all the address fields (which are set to format:none) with extra < p > tags on each element. The second series does not add those tags.

Here is the code I am using:

<p><strong>{facilities:title}</strong><br />
    {facilities:facility_street_address}<br />
    {facilities:facility_city}, {facilities:facility_state} {facilities:facility_zip}</p>

If I go into the field properties and change it to XHTML and then change it back to none, it solves the problem for existing entries, but any new entries, revert back.

Does anyone know how to resolve this?

4
  • What version of EE are you using?
    – AllInOne
    May 12 '14 at 16:46
  • EE 2.8.1 Thank you.
    – forrest
    May 12 '14 at 17:10
  • Are the fields being populated through a profile:edit form, or through the control panel? Do both have the same issue? What is the fieldtype in use? May 13 '14 at 2:47
  • This is an ordinary channel that uses text fields for all inputs. It is housed and populated in a Profile:edit form.
    – forrest
    May 13 '14 at 3:35
3
+50

Not sure if you want to use a plugin or not but you could strip out anything you don't want using Hacksaw: http://devot-ee.com/add-ons/hacksaw

Something like this might do it for you:

{exp:eehive_hacksaw allow="<strong><br />"}
      <strong>{facilities:title}</strong><br />
      {facilities:facility_street_address}<br />
      {facilities:facility_city}, {facilities:facility_state} {facilities:facility_zip}
{/exp:eehive_hacksaw}
2
  • Hi rchrdg, thank you for the suggestion. I have not aversion to plugins. I tried it and it effectively strips out all html tags and it does recognize the < strong > tag, but it ignored the <br /> tag. Very strange. I am still very open to suggestions! Thanks.
    – forrest
    May 13 '14 at 17:23
  • Hello again. I had an idea come to me and wondered if I removed the / from the <br> tag if it would work. I tried it and it worked perfectly. Thank you for your help!
    – forrest
    May 13 '14 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.