0

I've just upgraded to freeform 4.1.7 from version 3 and am now getting the following error on form submit

The following errors were encountered

Missing required valid POST variable - params_id Return to Previous Page

the site is using Transcribe 1.6, If ii turn off transcribe the form submits fine. the site is using country codes so when the form is submitted it goes to /es/?ACT=82 or /en/?ACT=82

Anyone had this problem of know of a solution. Using EE2.7.3

many thanks!

Anyone? :'(

2

This Solspace thread describes probable causes for that error:

http://www.solspace.com/forums/viewthread/16547

If you’re having issues with the params_id error, I would look at whether EE and your server can read ACT URLs correctly (eg. http://mysite.com/index.php_ACT=123). Also, make sure the form isn’t being cached: that’s a common cause for the error

Had a lightbulb moment. Make sure the domain in the URL you’re using, the domain in the form’s action=”” attribute, and EE settings are all on the same domain. www. and non-www. domains are not the same domain.

1
  • Thanks for this answer it pointed me in the right direction – Bjørn Børresen Mar 27 '15 at 11:15
2

I got this just now with a combo of Transcribe and Freeform.

I think Transcribe messes with the fetch_site_index function of EE. In any case the POST action in my form was:

example.com/////?ACT=86

I fixed this by modifying line 3473 in third_party/freeform/addon_builder/addon_builder.php to just use site_index instead of the native fetch_site_index function:

So, instead of return ee()->functions->fetch_site_index(0, 0) . on that line I use:

return ee()->config->item('site_url') .

This fixed the issue.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.