1

I have the chequerboard / empty thumbnails showing up in Assets, for all images. Everything is working fine on the live site. So far I've tried:

  • Checking / applying 777 to all images and the cache/assets directories
  • Emptying the cache/assets/thumbs directory and clearing the browser cache
  • Updating any old dev server paths I could find in the db to the new
    path
  • Updating from Assets 2.2.2 to the latest, 2.3.2, clicked 'update modules' and cleared cache
  • Checking the network tool for the thumbs, I get 200 OK but 'Failed to load the given URL' under Firebug. This is most likely because the files aren't there, I know because I have uploaded a thumb from the dev site cache and that worked.
  • Don't think it's .htaccess, have not changed that recently, but it is set to remove index.php but not www. The index.php?ACT query seems to be working fine as the thumbnail test above shows.
  • Checked User session is set to cookies only
  • Cleared EE data caches

The images were uploaded via Assets at dev, http://prometheus.glue.co.nz (ignore it, it's broken now), then went live at http://www.prometheus.co.nz two months ago. Guess the problem started then and went unnoticed. Same host so server paths not all that different. Oh, running PHP 5.3.10 and EE 2.7.2.

Please help? Hoping P&T crew would like to log in.

  • Did you checked your GD or Imagick settings? – Robson Sobral May 15 '14 at 11:46
1

I switched EE's resizing preferences (Admin > System Administration > Image Resizing Preferences) from ImageMagick to GD 2, deleted the contents of the cache/assets/thumbs directory, and on revisiting Assets module, the thumbnails all regenerated as hoped.

In places I'm using Assets in a Matrix field, and processing them with CE Image in the templates, so while it's early days, it seems like a robust solution.

I'd have loved to find out why but I've lost too many hours to this already. If you have to press on with ImageMagick for any reason the most likely culprit would be the path setting, required only for ImageMagick, which may not have been correct, or maybe ImgeMagick was not even installed by my host on the live account space...

| improve this answer | |
0

I had that same issue this morning as it happens. Turns out that when the files were uploaded there was a permissions problem with the cache directory.

So, check the perms for your system/cache directory and all sub directories are set to 777

I then had to re-upload the files to get the thumbnails to generate. Simply clicking the refresh button didn't work. The nice thing is that you can still view each file and download it then re-upload it with the same name so it overwrites the original.

I only had a few images to deal with and they were only used within 1 matrix field so I could delete and re-upload them directly so the change in asset ID wasn't a problem.

| improve this answer | |
  • Thanks, but no luck - double checked the whole cache folder and subfolders were 777, tried reuploading, and uploading a new file but no joy. – pixelace May 14 '14 at 12:39
0

Ran into the issue with Assets 2.3.2 and EE 2.8.1. After giving the cache directory proper permissions and making sure the proper domain name was being requested, the issue remained. I finally solved it by removing a line of code from the Assets module:

File: mpc.assets.php
Line: 179

    #header_remove('Pragma');
    readfile($thumbnail_location);
    die();

Not sure why header_remove() was causing an issue, but I have thumbnails now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.