0

I was upgrading my client’s website from a pretty early version (around 2.4 or something) to the latest. I followed all the steps in the upgrade process and when it started I could see it incrementally making upgrades.

However, it came up with this error after a while:

{“error”:” Error Number: 1060</p>\n\n Duplicate column name ‘includeseconds’</p>\n\n ALTER TABLE exp_members ADD \n\tinclude_seconds char(1) DEFAULT ‘n’ NOT NULL AFTER time_format</p>\n\n Filename: /www/eh20217/publichtml/system/codeigniter/system/database/DB_driver.php</p>\n\n Line Number: 382</p>”}

I then tried to do the upgrade again but it keeps carrying me to a blank page. I did some googling and decided to delete the safecracker folder from third party but that’s no help

I’ve tried deleting the installer folder but when I do that the control panel appears as blank.

I tried moving the installer folder to the root and then turned off extensions via config:

$config[‘allow_extensions’] = “n”;

And I actually get to the CP login screen but once I submit it goes to a blank page. I’ve deleted switchee from the third party folder because I also saw that someone was getting issues with that plugin when upgrading, but it hasn’t helped.

I also posted this as an urgent ticket since yesterday but I guess as it's weekend response time is slow.

Any help would be appreciated!

0

There were a few issues, all to do with outdated addons, which EE's support were stellar about investigating and fixing:

After turning on debugging this came up:

Fatal error: Call to undefined method Category_model::get_categories() 

This was caused by the Developer accessory and updating it fixed the issue.

Then we had 2 fieldtypes with the same issue - one was carthrob_matrix and the other was pt_switch. This was the basic error:

Fatal error: Call to undefined method EE_Fieldtype::EE_Fieldtype() in /www/redacted/public_html/redacted/expressionengine/third_party/cartthrob/fieldtypes/ft.cartthrob_matrix.php on line 40

And we fixed it like this: http://devot-ee.com/add-ons/support/simple-s3-uploader/viewthread/12869

We also had another issue with imgsizer:

Call to undefined method EE_Functions::remove_double_slashes() in /www/redacted/public_html/redacted/expressionengine/third_party/imgsizer/pi.imgsizer.php on line 42

It's really old and was calling a deprecated function. Robin switched out reduce_double_slashes() from the string helper for remove_double_slashes() and that seems to have it working.

The lesson is obviously to upgrade all addons before upgrading and to upgrade your EE installation often, don't wait 2 years ;(

Again, Robin at EllisLab was really great in tracking all this down and helping to fix it.

  • 1
    Please, mark your answer as right. – Robson Sobral May 19 '14 at 21:11
  • 1
    I'm planning on it but I have to wait a certain number of hours before I'm allowed to. – Tony May 20 '14 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.