1

I've set up a staging server for an existing EE2 website, when I make changes to templates and save most templates save ok, but when I try to save a template that has an EE query tag, I get the following error and it fails to save: 'You don't have permission to access /system/index.php on this server.'

If I remove the query tag, it saves with no problems.

1 Answer 1

3

You may want to check if mod_security is installed on your server and either disable it or change the configuration. My guess is that your issues is that mod_security is seeing the SQL query in your query tag and blocking the submission.

4
  • The host's support has offered to disable mod_security for his domain, is that advisable?
    – wot
    May 19, 2014 at 20:06
  • Yes, I think that would be fine. May 20, 2014 at 12:16
  • It didn't work unfortunately
    – wot
    May 21, 2014 at 9:44
  • Correction, it did work (the wrong domain was changed originally)
    – wot
    May 21, 2014 at 10:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.