2

Getting this error when updating to 2.5.5 from 2.5.4:

A PHP Error was encountered
Severity: Notice
Message: Use of undefined constant IS_FREELANCER - assumed 'IS_FREELANCER'
Filename: core/EE_Config.php(197) : eval()'d code
Line Number: 1

I updated using the quick method via this blog post: http://ellislab.com/blog/entry/expressionengine-2.5.5-released

Do I need to set a config variable for IS_FREELANCER in my config.php?

7
  • Copied over files from the /system/expressionengine/core directory, but now I have several other areas littered in the CP with errors like: A PHP Error was encountered Severity: Notice Message: Use of undefined constant IS_FREELANCER - assumed 'IS_FREELANCER' Filename: _shared/footer.php Line Number: 5 Jan 2 '13 at 16:30
  • My version number is showing up as Freelancer v2.5.5 for some reason, too. Jan 2 '13 at 16:31
  • 1
    Make sure you have all the latest files from the EE download archive. There should be no instance of "IS_FREELANCER" anywhere in 2.5.4 or 2.5.5. Perhaps your original 2.5.4 upgrade wasn't complete.
    – Kevin Cupp
    Jan 2 '13 at 17:30
  • I tried a typical EE upgrade using these instructions and got a couple bizarre errors. First, immediately when I tried to upgrade I got this error. When I tried to run the upgrade again I just get this error. Nothing in PHP/Apache/MySQL error logs. Jan 3 '13 at 12:49
  • 1
    Looks like this is a Structure issue. I changed $debug to 1 in admin.php and got numerous Structure errors. Will report back. Jan 3 '13 at 12:58
1

I asked the Structure crew for some help and they supplied me with a hotfix for the issue. I believe it is built into the stable version now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.