1

I'm getting an error when I try to add a wygwam element to my content elements field - but it only happens in my local dev environment. It works fine on our live site. Also, a stand-alone WYGWAM field will not initialize either, so I don't think the issue is with CE.

PHP 5.3.2 EE 2.8.1 Wygwam 3.2.2 Content Elements 1.6.6

Uncaught TypeError: Cannot read property 'init' of undefined
/themes/third_party/content_elements/elements/wysiwyg/ckeditor/ckeditor.js:24

Anybody seen this before? Thank you in advance!

2

If I recall correctly, then it was not possible to have CE RTE and Wygwam on the same page due to conflicting CKEditor instances.. If you switch out all your CE RTE fields for CE Wygwam fields, it should work again.

2
  • Hey Andris! Thanks for checking into this. I tried creating a new entry with only Wygwam within CE (no CE WYSIWYG fields) and it's still not initializing. Is that not what you were getting at? Thanks! – Brian Kalwat May 27 '14 at 18:35
  • Removed WYSIWYG element from the CE field and it's working great! Thanks Andris! – Brian Kalwat May 27 '14 at 18:42
1

First, try deleting and re-adding the entire Wygwam folders as there may be a corrupt or missing file.

Second, update to the latest Wygwam (3.3.1 now).

5
  • Hey Stephen, if it was a version issue I don't think it would be working in my live environment. Also, both codebases are off of the same repository, so I don't think I have corrupt or missing files. – Brian Kalwat May 27 '14 at 16:40
  • Good point. Still worth a try as an update might overcome some server nuance you have going on. – Stephen Callender May 27 '14 at 17:29
  • I tried updating to Wygwam 3.3.1 and Content Elements 1.6.10 to no avail. – Brian Kalwat May 27 '14 at 18:00
  • Both servers are running the same PHP? Are you on MAMP locally? – Stephen Callender May 27 '14 at 18:14
  • Our live servers are running 5.3.27. I am running MAMP locally and i've tried both 5.3.20 and 5.4.10. – Brian Kalwat May 27 '14 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.