2

Trying to use the P&T List from the Fieldpack within Content Elements and the values do not seem to parse. Example code:

{exp:channel:entries channel="page" ...}

  {!-- Content Elements Field --}
  {cf_page_body}

    {textarea}
      <p>{value}</p>
    {/textarea}

    {fieldpack_list}
      <ul class="compact-list">
        {values}
          <li>{item}</li>
        {/values}
      </ul>
    {/fieldpack_list}

  {/cf_page_body}

{/exp:channel:entries}

The output does not seem to get parsed only for fieldpack's list element in CE, neither the "values" tag pair or the "item" var - i.e.; it's returned as:

{values}
  <li>{item}</li>
{/values}

Any ideas? I've tried numerous variations on the fieldpack's list Content Elements tag syntax in case it is a documentation error, tried running the values through Stash as a stash list with parse depth set accordingly, setting parse="inward" on the EE channel tag, but to no avail.

Project Setup Info:

  • ExpressionEngine Ver. 2.7.3
  • Content Elements Ver. 1.6.10
  • P&T Fieldpack Ver. 2.1.1
  • Stash Ver. 2.5.3
0
1

In case any others might be struggling with this annoying problem: it's a compatibility issue, get the latest Field Pack (2.2) and everything works as it should :)

The Field Pack Changelog lists the following updates for Content Elements support:

  • Added support for {element_name} tags within Content Elements.
  • Fixed compatibility issues iwth Content Elements.

http://docs.pixelandtonic.com/fieldpack/changelog.html

1
  • also don't worry about data loss when you activate field pack P&T will be deactivated automatically. and your data is 100% secured during this process. – user3440483 May 26 '15 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.