1

I'm trying to use the MX QR Code Generator and using a very basic example from the website like so;

<img src='{exp:qr_code type="" action="tel" tel="1234567" data="ExpressionEngine" title=""}' alt="QR code"/> 

When I load the page Safari just throws "Safari can’t open the page “http://mydomain.tld”. The error is: “cannot decode raw data” (NSURLErrorDomain:-1015)" error.

There is a type parameter in the code as well, but the documentation on the site has no reference to this.

2
  • Does safari throw that error for the generated image, or the page that contains it? Jan 3, 2013 at 18:03
  • Hey Adrian. It's the whole page that is replaced with that error. Jan 3, 2013 at 20:55

2 Answers 2

2

I made quick update - try a version 2.0.5. you can find example on demo-ee

ok. the issue was with image folder - if you use not standart image folder ('/images/'):

img src="{exp:qr_code type="" action="" tel="" data="asdasd" title="" email="" subj="" size="10" alt="QR code" base_path="SERVER_PATH_TO_WEB_ROOT"  base_cache="SERVER_PATH_TO_QR_CODE_IMAGE_FOLDER"}"/> 
0
1

I'm not positive, but I'm pretty sure you shouldn't be using the data="ExpressionEngine" parameter when you're using the tel action. I think it's an either/or situation with tel/data/email parameters. The data="" parameter is used for URLs and other data types.

4
  • Hey Jeremy,Sorry - didn't seem to get a notification of your reply. I removed the data="ExpressinoEngine" but still seemed to get the error. I think it must be due to the type="" but I can't seem to find a reference to what needs to be passed in there. :/ Jan 11, 2013 at 11:03
  • I'd suggest leaving type="" out. It looks like it accepts type="J" if you want the QR code to be a JPEG otherwise it comes out as a PNG. Jan 11, 2013 at 14:56
  • Yeah, I tried leaving it out altogether but it still borked. :( Shame there isn't another plugin that does the same sort of thing that works. Heh. Jan 11, 2013 at 15:27
  • Yeah. Hm. I will check it out later today. I know I've used it before without an issue. Jan 11, 2013 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.