I am trying to bring a slightly older site back to life. It's currently on 2.1.4 and I am trying to pull it right up to date. There appears to be something going wrong somewhere as I am receiving database errors...

It is in or around ud_215 I think as this is where the error is reported. It appears to be attempting to create some duplicate fields in db tables - although I am aware that this may be because I have attempted to run the updater a couple of times. I've tried dropping the fields manually from the tables and re-running but I continue to get errors.

I ended up changing the software version in config.php to show as 215 and everything appeared to run okay - but on accessing the control panel I can tell that there up upload path issues somewhere.

I appreciate it's a long shot that someone else may have had similar issues - but where better to ask!? ;-)

  • It's worth asking — how big is your DB? ExpressionEngine support mentioned to me at one point that very large DBs are supposed to trigger a "lots of data" upgrade mode, but it doesn't always kick in.
    – Tim
    Jan 3, 2013 at 20:40
  • To be honest it's tiny - it was a site that only got half developed and then sat on a dusty shelf for a year or so. It's only got a few channels with very little data in them as yet. Jan 4, 2013 at 10:51

3 Answers 3


I had this happen to me recently as well, upgrading a DB from 1.7.3 to the latest.

Even if you are in the DB and can respond to each error, the maddening thing is that as soon as you fix one error, it restarts the whole process for the version number it's on, meaning that you have to fix the entire list of errors, or it will simply re-choke on error number 1 again.

I ended up backing up the DB, then running the update to catch the next error.

I would then update my backup to fix that error, trash the version I just ran the update on, then create a new copy of my backup to run the installer against again.

It was a bit of a nightmare, but I made it through.


Okay so this one is a bit strange but I got it to run in the end! I thought I would post my own answer in the hope that it may help others if they come across this issue themselves...

Having rolled back to 2.1.3 a few times (that was fun!) and running through the update whilst watching the expected changes to the database I discovered the following:

  • The upgrade to 2.1.4 was running fine and updated the config to version 214
  • The upgrade to 2.1.5 had in fact completed but for some reason was attempting to run again!

I compared the config file on my backup to the new one and the only major difference was that the version number variable was wrapped in " in the new file and ' in the old. Now I am pretty sure that really shouldn't be an issue, however I changed the new file from "215" to '215' and saved it. I then re-ran the updater and it sailed through fine!!!

At this point I had to re-sync the file uploads (a requirement of the 215 version notes) and the site is up to date and functioning again.

Just to add a twist, when I checked the config file on my now 2.5.5 install the version is wrapped in double quotes again!? :-)

Thanks to those who added their help to this one though - nice to see the community support is still there and willing to help :-)

  • 1
    Great! Not that you had to rollback multiple times, but that you identified the issue and fixed it. Quotes are tricky. I know for one of our clients, I always use single quotes ' because the double-quote occasionally produces issues with the PHP. I've never troubleshooted why, since its a hosted server. Just a note, you can accept your own answer so that the issue is marked as resolved. Jan 5, 2013 at 15:41

I had a serious of similar issues happen to me during an upgrade from EE 1.7.3 to EE 2.5.2. The darn duplicate field, can't add 'fieldname' cause it already exists. First thing, first… did you perform a backup of your database? If yes, can you rollback full to EE 2.1.4?

Then re-start the upgrade process from there. It's not ideal, but will get you a clean beginning.

  • Being the ever professional I did perform a full backup :-) I will roll it back again and give it another shot. Did it run through okay with you second time round? Jan 3, 2013 at 18:52
  • My second time went smoothly for the actually EE upgrade, but towards the end it tried to do an update to IP-to-Nation module, which I don't use, but was installed. That lead to me tracking down the update for that and just adding _old so that process finished. Then uninstalling module after the fact. I hadn't realized it was installed before I was doing the update. I have had upgrades, where I've had to comment out // ALTER STATEMENTS though. But that's because I couldn't rollback. A full database backup is useful. Jan 3, 2013 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.