0

When a member registers on my site, I want them to first verify their email address before they can log in the site. Right now, when a member registers, they are automatically logged in. Is there a way to prevent this? I don't see any option for this in Members Preferences.

FYI: I'm using Safecracker Registration and Membrr, too. Not sure if this matters.

UPDATE 1:

Clarification: the members are being logged in PRIOR to them verifying their email. The system is already set up in such a way that the user needs to verify their email address first. The problem is that their instantly logged in when they sign up (without having to click the activation link in their email).

2

If you check out the Require Member Account Activation options in Membership Preferences section of the User Guide, you'll see the self-activation via email option which will do exactly what you're asking.

UPDATE

Based on additional feedback, the Safecracker Registration add-on being used was automatically logging the members in, even though their accounts weren't yet activated. Setting the loggin_member="no" parameter on the registration form resolved the issue.

| improve this answer | |
  • Sorry, I wasn't clear in my question. I am already requiring members to verify their email address. The problem is that they are logged in already prior to them verifying their email address. – ExpressionEngineNewbie Jan 4 '13 at 20:50
  • I think one of your two add-ons may be causing this, then, as users are not supposed to be allowed to login until the account is activated. – Jeremy Gimbel Jan 4 '13 at 20:53
  • Check the documentation for Safecracker Registration (objectivehtml.com/safecracker-registration/…). There's a loggin_member="no" which can be sent to prevent automatic login. – Jeremy Gimbel Jan 4 '13 at 20:54
  • I have a solution for this but am out the office. I will get back with you later. – Justin Kimbrell Jan 4 '13 at 20:55
  • 1
    @JeremyGimbel, loggin_member="no" fixed the issue. I thought I read this somewhere, but was convinced it was a settings in EE's members module. Thanks. – ExpressionEngineNewbie Jan 4 '13 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.