4

Running into an issue with CE Image 2.4.1 on an ExpressionEngine 2.5.3.

The code below is grabbing an image from a Matrix 2.5.2 field. In the first line, with the tag, the image displays as expected. In the second line, where CE Image enters the picture, the image neither appears nor is cropped.

{work_process_gallery}
  <img src="{mx_image}" />
  {exp:ce_img:single src="{mx_image}" width="200" height="200" crop="yes|center,center"}
{/work_process_gallery}

Following the troubleshooting instructions on the CE Image website, I enabled Template Debugging and I am seeing this when I load the page:

***  CE Image debug: Base path: '/usr/local/apache/htdocs/'
***  CE Image debug: Source image: '[REDACTED_URL]/images/uploads/adidas-apparel1.jpg', Fallback image: ''
***  CE Image debug: Source image is not readable or does not exist: '/images/uploads/adidas-apparel1.jpg'.
***  CE Image debug: Fallback source image is not readable or does not exist: ''.

If I take the URL from the second line, the image loads as expected in my browser, so isn't the source image both readable and exists?

4
  • Do both your upload directory and your CE Image "made" directory have 777 permissions?
    – kmgdev
    Jan 4 '13 at 21:42
  • They have 755, as mentioned in the Setup section of the CE Image docs. Changing them to 777 had no impact. Jan 4 '13 at 22:13
  • What about the permissions on the image files themselves? I've sometimes come across instances where the folders had correct permissions, but files didn't.
    – Tyssen
    Jan 5 '13 at 12:16
  • @Tyssen the images are also 777. This might be connected to the fact this is on a development preview server, found something in the CE Image docs which supports this theory. Haven't had a chance to revisit this yet. Jan 5 '13 at 23:55
4

Brooks,

The image may exist at the url, but, the base path may be the issue if it's not pointing to the public folder. The debug gives the base path as,

/usr/local/apache/htdocs/

and then you have the route to the image as,

/images/uploads/adidas-apparel1.jpg

Which means that the image needs to be in,

/usr/local/apache/htdocs/images/uploads/

Without knowing the server set up I am guessing, but I would expect to see a public or public_html directory somewhere in the mix, which may be the issue.

If your permissions and the (full) path above is correct, then there is another issue that cannot be determined with the details we have here.

1
3

I believe I came accross something similar and using pair tags instead of single tag worked. I never did get a chance to figure out why but refer to the docs for pair usage. Also try adding parse="inward" to your matrix tag, a plugin within a plugin may be in play.

0

Brooks were you ever able to get this working?
on a new server move I keep getting no images where CE Image is referenced.. single or paired tags. My debug looks like this

(1.030295 / 13.96MB) *** CE Image debug: Base path: '/pathto/my/public_html/'

(1.030330 / 13.96MB) *** CE Image debug: Source image: 'http://correcturl.com/assets/domain/upload/posting/Dinosaur_(1).JPG', Fallback image: ''

(1.030350 / 13.96MB) *** CE Image debug: The image '/pathto/my/public_html/images/made/assets/domain/upload/posting/Dinosaur_(1)_1000_667_80_col-255-0-0-0.JPG' is not cached.

(1.030366 / 13.96MB) *** CE Image debug: A problem occurred trying to open the image '/pathto/my/public_html/assets/domain/upload/posting/Dinosaur_(1).JPG'.

Can you see my error? I've cleared cache for the tag and have added $config['ce_image_document_root'] = '/pathto/my/public_html/' to the config.php

I'm lost for my options from here.

2
  • Maybe? This project was so long ago and I no longer have access to that site so I can't confirm what the fix might have been. I'm guessing it would have been something related to either permissions or a slightly off path. I encountered something similar last night (images weren't showing) and the fix was to set the folders as writable. I still need to test it more (see next comment) as I was testing some proof-of-concept stuff and instead of spending much time on it, just manually set permissions. Jun 11 '15 at 14:45
  • So, the issue (in my case) might be that CE Image is running into issues creating writable directories on the server. Jun 11 '15 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.