2

Suddenly, We are not able to edit and Channel Fields. We are using: EE v2.8.1 - Build Date: 20140314

If we go to: Admin > Channel Administration > Channel Fields > Example Group > Slider Image and not even change any values but simply hit "Update" button

its giving error saying: disallowed key character

We did some google and we tried all different solutions: clearing Cookies, Cookie Prefix but nothing is helping

any help or pointers to solve this issue will be of great help. Also same error comes up if we edit any template and if that template has a word like name="fullname"

see screenshot attached for the page we are hitting update that gives us error. enter image description here

  • 1
    Could you try this, eeinsider.com/tips/view/disallowed-key-characters, and let us know what the error says afterwards? – Mutual Jun 10 '14 at 7:43
  • 1
    Hi Andrew, we are using EE v2.8.1. We can see two files: 1) \system\codeigniter\system\core\Input.php 2) \system\expressionengine\core\EE_Input.php but there is no file called: core.input.php we did find the same thing in \system\codeigniter\system\core\Input.php and after we did the change the result was: Disallowed Key Characters:/cp/admin_content/field_edit?S – Aninda Jun 10 '14 at 13:07
  • 1
    ExpressionEngine 2.8 introduced cleaner URLs to the control panel (ellislab.com/blog/entry/cleaner-control-panel-urls) This seems to be what's causing the problem. In your config.php do you see uri_protocol? What is that set to? – Mutual Jun 10 '14 at 13:46
  • Hi Andrew, Its Set to $config['uri_protocol'] = 'AUTO'; – Aninda Jun 11 '14 at 9:58
2

I had a similar issue recently on a VPS account – the local version worked. It ended up being a mod security setting that was preventing this from saving with the same error you mentioned.

Oddly this is the first time this issue came up with ExpressionEngine, despite being an issue with other CMS before using the same provider (Liquidweb in my case.)

Hope that helps.

| improve this answer | |
0

Thanks Everyone for your inputs

We finally figured out that is was a security settings which was activated by our hosting provider which was stopping any form to except characters like { } "


It was being blocked by security settings in Comodo WAF (which appears to be a little excessively strict in recent updates) and has been allowed now.


| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.