1

Link a page usign {path='site_index'}{page_uri} (inside an exp:channel:entries obviously) generate this url:

http://local.sitename.it:8888//centro-accoglienza/la-struttura

How can I remove the double slash after site_index? Is there a way to do that?

Thanks!

5
  • What does just the {site_url} variable return? – Michael Boyink Jun 10 '14 at 20:12
  • It returns http://local.sitename.it:8888/ – Edoardo Stefani Jun 11 '14 at 9:35
  • What's the page URI set to? – Michael Boyink Jun 11 '14 at 12:51
  • It is /centro-accoglienza/la-struttura. I tried to remove the first slash but EE re-insert it. – Edoardo Stefani Jun 12 '14 at 9:57
  • 1
    Can't you just build the link without the site_index portion? <a href="{page_uri}">View this page</a> ? – Michael Boyink Jun 12 '14 at 11:52
1

Your site URL in your site general configuration (or perhaps your config file, depending on how you set up) likely has a trailing slash which isn't needed. If you remove that it should fix it for you.

In "Admin > General Configuration" this is referred to as "URL to the root directory of your site"

2
  • I tried to do that but the double slash remains... – Edoardo Stefani Jun 10 '14 at 14:57
  • When removing the trailing slash where Andrew mentioned does the change 'stick'? In other words when you update that field and you view that settings page again is it gone? If not then your config.php file might not be writeable. – Mark Bowen Sep 8 '14 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.