1

New channel entries have stopped displaying on the front end regardless of channel or MSM site.

I see the new entry in EE backend, but it's not showing on the front-end pages/site.

{exp:channel:entries channel="test" site="customers" show_expired="yes" show_future_entries="yes" dynamic="no" status="open|not closed"}
{title}
{/exp:channel:entries}

What's odd is if I add limit="100" (or any number for that matter, and even other tags as well) it will start displaying the new channel entry.

  • Not much to go in here. Please show us more template code. Have you tried turning template debugging on? Did you make any changes to the site concurrent with the arrival of this trouble? – AllInOne Jun 16 '14 at 18:40
  • @AllInOne I believe the issue started after upgrading from 2.6 to 2.8.1. The template code is pretty straightforward. {exp:channel:entries channel="test" site="customers" show_expired="yes" show_future_entries="yes" dynamic="no" status="open|not closed"} {title} {/exp:channel:entries} - If I add one entry to this channel it will display but any further entries will not. If I change any of the channel parameters such as limit, set future entries to "no", etc. The new entries suddenly display. – mbommel Jun 16 '14 at 18:47
  • It's best to add your code to your question. status="open|not closed" seems strange to me. Wouldn't status="not closed" be a simpler way of saying the same thing? – AllInOne Jun 16 '14 at 22:02
  • Yeah, with that status I was basically trying anything to see if it had an effect on the issue. I have a ticket with EE support right now on the issue, so I'll update this post when I get a resolution. Thanks. There isn't any specific code causing the issue, so it's kind of beside the point. It's an issue with any template listing any channel entries on any site. – mbommel Jun 17 '14 at 22:13
  • What are you trying to achieve by showing expired and future entries? – AllInOne Jun 18 '14 at 21:31
2

I was able to resolve the issue by setting $config['enable_sql_caching'] = 'n'; in config.php (you can use the configuration file editor as well). Apparently the issue has to do with having multiple sites/embedded templates. I think EE isn't clearing the cache on new entries in cases where I am using multiple embeds/sites in templates. EE support is considering this a caching bug and has passed it off to the developers.

| improve this answer | |
0

I have had a somewhat similar issue with EE 1.7.3 We just switched servers over the weekend... we had been on the previous server for about 5-6 years. All worked well. Then we put up a couple entries in different weblogs (now "Channels" in 2.x) and noticed that, even though you could put them up in the EE control panel, they did not appear on the website. ?? So. You could put up entries without problems. They showed in the EE preview. The entry data was placed in the database in the correct tables (checked). The entry did NOT show up on the web page. Yet no code had been changed. IF, however, I changed the Limit="__" number from whatever it used to be (7 or 22 in the main two cases), the new entries showed up. ??!?? So on one template I changed the Limit="7" to Limit="8" and the other from Limit="22" to Limit="21" (a smaller number just to check) and, lo, it all works.

I'm not adding the code in here simply because the code is basic and has not changed in years. The only change was the server. Yet EVERYTHING works but that.

Why this happened / happens, I do NOT know. Just letting you know that it does.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.