0

I am using the wygwam add on, and clicking the "read more" icon to create an excerpt. However, whenever I do this, it creates a paragraph tag around the text before the read more and starts a paragraph tag for the text after the read more. For instance, when I click view source, I see this:

<p>some text</p><!--read_more--><p>some more text</p>

I can view source and remove that /p before and p after, and that works fine. But if I wanted to stick to WYSIWYG, how do I eliminate those paragraph breaks. What I essentially want is a solid block of text without paragraph breaks when the extended portion is showing.

1
  • What happens if you place the read_more within a single <p> tag pair? As in don't end the tag before and re-start it after the read_more? Thus <p>some text<!--read_more-->some more text</p> Does that address the issue?
    – dashard
    Jul 11 '14 at 4:15
0

I'm not sure if it will work as this is a special feature of Wygwam but try using a soft return (SHIFT+RETURN) instead of a hard return. This will use a
tag instead of a

tag pair.

Of course, this will still cause a new line but you might be able to mitigate that via css by setting the
tag to be inline.

1
  • 1
    Thanks for the comment, foamcow.. the soft return solution didn't work, but your mention of CSS was useful. I ended up being able to work around the extra p tags... they're still there, but I'm using CSS to style it as if they aren't there. Thanks!
    – dcpl
    Jun 22 '14 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.