0

I have just installed Assets. But it keeps logging me out of the CP. This error occurs (console): POST http://centiv.local/admin/ 500 (Internal Server Error) It contains: {"error":"

This form has expired. Please refresh and try again.</p>"}

This happens when I:

  • Visit Modules -> Assets.
  • Try to upload a file in a Assets field.

I have added this to my config file: $config['disable_csrf_protection'] = "y"; This doesn't give an error but a blank page when I try to access assets from the field in a channel, it say's I'm logged out of the CP.

I don't know what's going on here, any help would me much appreciated! :)

Assets: 2.3.2 ExpressionEngine: 2.8.1

  • Have you checked your error logs? – Andris Sevcenko Jun 20 '14 at 11:38
1

A white page in EE pretty much always means a PHP error that is being suppressed.

Here are details from the EE docs on how to troubleshoot blank pages:
http://ellislab.com/expressionengine/user-guide/troubleshooting/general/blank_pages.html

Follow these instructions until you are able to see the error message(s) being output by your server:

Open your site’s main index.php file and under the Error Reporting section change:

$debug = 0;

to:

$debug = 1;

Go to Admin ‣ System Administration ‣ Output and Debugging and ensure that Debug Preference is set to 1: PHP/SQL error messages shown only to Super Admins.

Go to Tools ‣ Utilities ‣ PHP Info and search the page for “display_errors”. Ensure it is set to On under the Local column. If it is not, your host can help change this setting for you.

Check your server’s error logs or contact your host to assist you in cases where errors are being output to logs and not to the screen.

| improve this answer | |
  • Hi Anna, Thank you for this answer! I'm sorry but I havent formulated myself clear enough. The page isn't actually a blank page. It says something along the lines of: You are logged out of the control panel. The errors I'm getting are visible through the console as stated above. – Dion Snoeijen Jun 21 '14 at 15:02
0

Aha, I have found the problem! It was a the setting: "URL to the root directory of your site" under "General configuration" that contained a wrong path :).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.