1

I have recently starting having an issue in which the submit entry has begun to take between 10-20 secs to publish.This has happened over the last few weeks and Im no sure whats going on .Looking at it in firebug the post element seems to wait for the period of time before it completes. I recently upgraded to EE2.8.1 but this problem existed before and still happens now the upgrade is complete.

This seems to happen across all channels no matter what fields exist in them .I setup a test channel with a field set with just a text box but the same issue occurred so it doesn't seem to be a issue with an individual plugin.

Thanks for any help

Brian

  • 1
    Even though you've tried creating a new channel with no third party fieldtypes, there may still be extensions from other fieldtypes running. Take a look at your extensions list. You might update your question with your list of enabled extensions. Beyond that, it could just be a slow database. Is the front-end of the site also slow? Also, what host are you using? – Jeremy Gimbel Jun 23 '14 at 15:07
1

I went ahead disabled all my extensions and the delay disappeared. I disabled them one by one and supersearch turned out to be the culprit.

Looks like there is an issue the the supersearch index which is causing the delay.It is with Solspace support at the moment so i will update with their solution

| improve this answer | |
0

It's the same here.

I opened a Ticket in Solspace and the answer is:

The slowdown could be caused by Super Search indexing the data during save so that it can be used in searches later.

Also, are you using the "Channel Refresh" cache refreshing option in Super Search (in the CP, in the "Preferences" tab, under "Refresh Rules")? If so, you might want to consider using the "Refresh" option only by setting Super Search to refresh cache only at a set interval (eg. 10 minutes).

| improve this answer | |
0

Just an update on this , it turned out it was related to the the search terms and seach log tables in my database. They had grown to over 300 MB between them and made up about half my database size. This information wasn't important for me so I truncated the tables turned off search logging in the settings. Everything works ok now with my save entries working as normal and my database is now a more manageable size.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.