2

If I add this code using WYGWAM source

<h2 class="section-title">Some<span class="blue-text long-word">Title</span></h2>

and publish, it works fine.

But if I go back and edit the entry and click source again all the classes are removed.

How do I keep WYGWAM from removing all my classes?

8

Go to Add-ons > Modules > Wygwam > Editor Configurations and select the configuration you want to edit.

Look for the Restrict allowed HTML? setting and make sure it is set to No.

wygwam restrict html setting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.