1

I downloaded a current copy of my production database into my development environment. Both the production and development environments are EE v2.4.0. When I logged on to the control panel I received the following error message:

An unexpected error occurred attempting to download the current ExpressionEngine version number. Please visit your Download Account to verify you are on the current version. If this error persists, please contact your system administrator

What is EE checking to determine this? How do resolve it.


UPDATE

My apologies to all readers. It is not EE 1.4 but it is EE2.4. My apologies to all respondents.

  • My apologies to all readers. It is not EE 1.4 but it is EE2.4. My apologies to all respondents. – pgikkas Jun 30 '14 at 1:35
3

You will want to open up your CP and navigate to Admin > System Preferences > General Configuration and scroll down to New Version Auto Check and set that to "No". From the EE1 docs:

New Version Auto Check

Enabling this feature will cause a message to be displayed in the Control Panel when a new version of ExpressionEngine is available. It will not automatically download and install a new version.

The reason that you are getting the error is because in EE1 the update script was looking for an xml file on http://expressionengine.com but since EllisLab unified their offerings into the http://ellislab.com domain name it broke things like this. Once you disable the new version check in the CP the error should disappear and there is nothing wrong with getting the error other then it being a pain to see it all the time.

Having said that you are fairly far behind 1.7.3 I think was the last EE1 version and we are currently at 2.8.1 I think with EE2.

| improve this answer | |
  • 2
    We actually include redirects for the old URLs, but 1.4 was probably accessing a resource that didn't even exist when 1.7.3 was released. 1.4.0 is almost 10 years old, and should probably not be run in a production environment. – Derek Jones Jun 27 '14 at 17:32
  • 1
    @DerekJones I have seen this before on EE1 upgrades I have done but I think they were all pre EE 1.6 so that makes sense that it would be causing problems or not have had a redirect included. Definitely recommend upgrading the site to at least 1.7.3 if not to 2.8. There weren't a high amount of add-ons when 1.4 was around so it should be a fairly painless upgrade. – Justin Long Jun 27 '14 at 19:14
0

A proviso on this answer , it applies to expression engine 2 + , im not sure about EE 1.4 as its so old but its worth a look anyway

Go and edit yourconfig file in /system/expressionengine/config/ .

The first item in the config items list is

$config['app_version'] = "281";

281 in this case referres to expression engine 2.8.1 which i am running. If you are getting that warning your version of expression engine is different from the value in this config item .To fix it and get rid of the warning just change the value to match the version of EE you are running.

| improve this answer | |
  • 1
    A different error message shows up when the config variable is different then the version of EE you are running. This is the message that is shown when the xml file is not reachable for one reason or other. – Justin Long Jun 27 '14 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.