4

There's a button in the top right corner of every EE install that links to the front-end of the site. On one of my installs it's returning:

http:///

instead of the site's address.

Where can I change the setting for this button?

If you look at the html it's the anchor inside the "msm_sites" list item.

  • Are you using a htaccess to remove the index.php? In that case, you should add RewriteCond %{QUERY_STRING} !URL in order to skip the URL query string – pvledoux Jan 7 '13 at 17:01
  • I'm removing index.php but I do that on all my EE sites and they don't have this problem - so I don't think this is the issue. Thank you though. – Jeremy Latham Jan 7 '13 at 18:01
2

That link comes from Admin → General Configuration - the setting named URL to the root directory of your site. I'm willing to bet you have "/" as the value there.

| improve this answer | |
  • Thanks Derek - URL to the root directory of your site setting is what it should be: clientsite.com - any other ideas? – Jeremy Latham Jan 7 '13 at 17:28
  • 1
    Check for $config['base_url'] and $config['site_index'] in your config.php file. Those values might be overriding the control panel if present. – Derek Hogue Jan 7 '13 at 18:12
  • You are a champion Derek! $config['base_url'] was blank. Thank you! – Jeremy Latham Jan 7 '13 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.