I'm trying to use the new channel form captcha functionality, and I never get the fields displayed, apparently because the {if captcha} conditional always fails. However, like one of the blog posts I saw, when I take the conditional off, I do get a display of the {captcha} image.

I have followed the instructions and have Allow Guest posts set to yes, Guest Captcha set to yes, And I yave Use TrueType Font set to Yes and that font is there in the {site_url}/images/captchas directory. I just re-affirmed for the second time that my images/captchas directory is set to 0777, although that may not be valid as it's a Windows server. I don't know how to check the GD library, but every other aspect of EE seems to work fine.

I am not able to see any evidence of GD library. As it's a windows server, I'm not sure where to look. Anyone know where in the GUI, or elsewhere, I can see that?


1 Answer 1


If you can see the CAPTCHA sometimes then you don't have a problem with permissions or the GD library.

Are you logged in to the site/CP when you can't see the CAPTCHA? There is a setting to show CAPTCHAs only to users that aren't logged in.

  • 1
    This is likely it. OP, try logging out or requiring CAPTCHA for members as well. Jul 31, 2014 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.