1

I'm in the process of installing EE on my website. All the information that I added in the data section are correct. I even contacted the host provider and everything that I have been doing seems right. However, I'm unable to proceed with the installation as I keep getting this message:

A Database Error Occurred Unable to connect to your database server using the provided settings.

Filename: controllers/wizard.php

Line Number: 1544

I would really appreciate the help on this matter.

2

Without a doubt the connection details are wrong in some way.

Have you created the database on the database server? The installer won't do that for you, it will simply populate a database with the necessary tables.

If you are using "localhost" then are the webserver and database server on the same network? (i.e. you don't have EE installed on your own machine but are attempting to access a database hosted elsewhere).

UPDATE: The OP was using the incorrect server host name. The fix was to use "localhost".

| improve this answer | |
  • To answer your question, yes I have created the database on the database server. I also didn't use localhots, I used the one that was provided by the server – user3282 Jul 1 '14 at 9:32
  • I agree with Foamcow. When this happens, you need to be extra careful and copy/paste the database info when installing. You could also try uploading this script to test your database settings pastie.org/9343669 – CreateSean Jul 1 '14 at 14:21
  • in the server address I added the number that appears in my bluehost account under "shared IP address". this is the only thing that I'm not 100% sure about. otherwise, all the information that I added are right. – user3282 Jul 1 '14 at 15:30
  • 1
    That is the IP address of your web server which may not be the same as the database server. Try using "localhost". – foamcow Jul 1 '14 at 16:16
  • That worked finally! Thank you so much. I had a feeling that I shouldn't be using the IP address when my host provider asked me to use it. Thanks a lot :) – user3282 Jul 1 '14 at 16:27
0

The first thing i would try is setting your System > ExpressionEngine > Config >

config.php database.php

to 666 permissions.

If this is not set right it won't be able to setup your database file in a readable way to connect to your servers db.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.