0

I have the following tag:

{exp:super_search:results
                orderby="date"
                paginate="both"
                limit="20"

            }

                <h3><a href="{page_url}">{title}</a></h3>
                <p>{if excerpt}{excerpt}{if:else}No excerpt available.{/if}</p>

                 ....
{/exp:super_search:results}

I have the correct excerpt field selected in the channel settings, cleared the cache, reindexed, etc. Still nothing appearing here. Any thoughts?

  • What version of Super Search are you using? What version of EE are you using? Have you tried just outputting {excerpt} (no conditionals)? Is the field set for the excerpt also set to be searchable? – Solspace Jul 3 '14 at 4:57
  • I'm using EE 2.8.1 Super Search 2.1.4. Outputting just {excerpt} doesn't generate anything and all the fields are searchable. – Jon Nixon Jul 3 '14 at 11:51
  • Short of asking if there's actually any text in your custom field associated with the excerpt, we would have to dig deeper. Feel free to file a support ticket at support.solspace.com and please mention this thread. We'll try to come back here with a solution. Thanks! – Solspace Jul 4 '14 at 2:18
1

After some testing, both the Super Search and the native EE Simple Search form had the issue. Here is the explanation and solution:

Your channel preferences indeed had a custom field set as your excerpt field, but this setting was likely not registered in the database. Re-saving the channel preferences should save the excerpt value in the EE database, and excerpts should appear in your results.

Repeat this for each channel that might be causing issues.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.