0

I've just updated the paypal express settings to use the LILVE api/creditials/signature and now the cart button is not working. I presume this is because the settings are incorrect. Is there anything else that could cause this to happen. Everything was/is working fine with the sandbox details.

Is there anything I need to do on paypal?

Thanks Dave

2
  • When you say 'not working' can you provide any further info? Is an error message displayed or is there just no response? Also, what did you change when switching to Live mode from Test mode?
    – Ian Young
    Commented Jul 4, 2014 at 17:38
  • Hello, sorry that was a bit vague! When you hit the pay button the page just reloads, doesn't connect to paypal. I have switched testing mode to false, no difference.
    – magicspon
    Commented Jul 5, 2014 at 13:57

1 Answer 1

1

If the page is reloading there are a couple things that you should do.

  • In the final step of your checkout process make sure that you have {error:payment_method} in your template (docs).
  • Remove error_handling="inline" from the opening checkout tag on the last page this will show the default error page instead of putting things inline which would only show up if you had the proper {error:field_name} tag in your template.

That should give you a good indication of what is causing the problem. I found in the past sometimes with PayPal you have to create a new API key to do that goto:

Profile > My Selling Tools > API Access > Request/View API Credentials (Option 2) > Request API Signature

You will then need to copy/paste those fields into the PayPal Express gateway settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.