1

I've got an EE 2.5.5 site and I'd like to be able to set the control panel language to Italian. I've followed the instructions on how to do this from the user guide.

I downloaded the Italian language pack from EllisLab's GitHub account, and I've uploaded the italian folder to system/expressionengine/language/italian. But when I set the language from english to italian, I get the following error:

An Error Was Encountered
Unable to load the requested language file: language/italian/core_lang.php

I have added an issue on GitHub, but not sure if that is being monitored closely by EllisLab so thought I'd post here for help.

Is that language pack out of date (as there's not even a core_lang.php file within the repository), or do I need to be doing this in a different way?

2

you're getting that error simply because the https://github.com/EllisLab/EE-Language-Italian pack is for EE 1.x versions.

Plus you can download this (though it's not 100% translated) at least it's a Version 2.1.3 https://bitbucket.org/age38dev/eecita/src/87fdcac9ce735f722f4cb182e40f51e42b92b043/2.1.3/EE/language?at=default

| improve this answer | |
  • Damn, I didn't even consider/realise that, as I just assumed the language pack in EllisLab's own repository (and linked to from the EE2 docs) would surely be for the current major EE version. Thanks for pointing this out and the alternative EE2 download. – Stephen Jan 8 '13 at 16:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.