1

I was upgrading an EE install from 2.5.2 to 2.5.5. First of all, I updated all the add-ons to make sure they were the latest versions. Then I added the new EE files as per the updating docs.

When running the upgrade, I got the following error message in a popup window after about 15 seconds:

The update script failed without returning an error. Please contact tech-support.

My hosting has plenty of memory (512mb) and execution time (60 seconds, though I even upgraded it to 600 seconds to rule it out as an issue) and has run dozens of upgrades before without any issues. I even tried upgrading from 2.5.2 to 2.5.3 instead, but got the same result.

7

To workaround the issue, I followed the advice from this EE Support thread by renaming the system/expressionengine/third_party folder to something else immediately before carrying out the upgrade. The upgrade then worked fine, and I renamed the third_party folder back afterwards and all was well.

The explanation for having to do this (from the same EE support thread as above) is that 'the updater is trying to run the update scripts of third-party modules, so moving them out of the way lets the updater complete, then you can update third-party modules after.'

I'm sure that all my add-ons were already updated before carrying out the EE upgrade, so I suspect I either missed one through human error (unlikely as I double-checked them), or there was a rogue add-on that was causing an issue with the EE update script (but it would have taken too much time to pin-point which one after the above workaround worked).

1

Possibly safecracker_file. Gave me some further problems after removing/replacing third part folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.