I’ve got an EE 2.5.2 site running on Dreamhost which we upgraded a while ago from 1.6.x. Ever since doing so all the images we upload via the File Manager seem to get some weird filter applied to them, and they end up looking like this.

Anyone else experience this problem or have a clue how to solve it?

  • Have you made sure to synchronise the file upload directory? Jan 8 '13 at 21:24
  • yes, in fact I believe everything got weird as soon as I applied the synchronization, and thereafter any images that I upload or use the image editor on get the weird filter applied.
    – vibe9
    Jan 8 '13 at 22:17
  • What version of the GD library and/or ImageMagick do you have installed? What happens if you try to use an image resizing add-on such as CE Image on an image you upload via FTP? This could help isolate the problem. Jan 9 '13 at 13:51
  • I'm running GD Version "bundled (2.0.34 compatible)"
    – vibe9
    Jan 10 '13 at 2:03
  • I've just tried running an image through CE Image and no errors were returned. It did indeed resize the image, however, because all of the images are getting the weird filter applied once they're uploaded, the resized image via CE Image still has the filter (because that's what was fed into it).
    – vibe9
    Jan 10 '13 at 2:11

It sounds like you may have a filter enabled for that file upload in the settings. Check to make sure there is not an Image Manipulation setting enabled in your File Upload Preferences by accident.

Also, if you are only seeing this image on the frontend and not in the control panel, check to see if you are using CE Image or some other image manipulation code that is possibly changing the image display.

UPDATE: I suggest that you upgrade to ExpressionEngine v2.5.5 to eliminate a bug in your EE version as the issue. This seems very unique to your server setup and EE install so upgrading EE is the first step.

  • @mediagirl - the only setting I have is "Maximum Image Width (in pixels)". This happens in the CP. I'm not using any image manipulation (or plugins) on the front-end at all.
    – vibe9
    Jan 8 '13 at 22:15
  • 1
    Yeah - me neither! Many EE sites, and never this.
    – vibe9
    Jan 9 '13 at 22:23
  • 1
    Does this happen using when you run the same site either locally or in a dev/staging environment? Or is it only running the site live on Dreamhost that the filtering occurs? Jan 10 '13 at 1:01
  • 1
    Also... do you have any watermark preferences set at all (even if you are not applying them to uploaded images)? Jan 10 '13 at 1:08
  • 1
    Sounds like maybe a setting for ImageMagick was triggered or set somewhere, maybe in the .htaccess or the php.ini file. Jan 10 '13 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.