For two particular (moderator) user groups, I have made a 'admin'-link that takes the user from pieces of content on the website, to the admin side - directly into the 'content->edit->entry' of that content. This to make it easier for moderators of a blog to edit certain pieces of content if necessary - without having to look for it again in the admin side.

The link I created looks something like this: http://thewebsite.com/admin.php?/cp/content_publish/entry_form?channel_id=14&entry_id=1202

This works - but the only thing is, everytime when the link is clicked the user first needs to login again (username, password) before getting into the admin part (even if the admin part is still open in a different tap). This is because in my link I miss a (presumably) salt part (which is there when I get to the edit screen using the normal admin login) - see the last part ==> http://thewebsite.com/admin.php?/cp/content_publish/entry_form?channel_id=14&entry_id=1202&S=efdf1b4699b93656ab6cbace8816add5

how do I get / create this salt part (S=****), to be able to sent a user directly into the admin part of the side? (maybe after a one time login, but not for every time). It is not the same as the salt column in exp_members.

Does anybody know what to do?

greets Rick

2 Answers 2


starting from 2.9 there is a new variable to link to the backend. For older versions either change admin - security settings to use cookies and/or session (try if that works).

Or use a bit of code in a plugin or extension to make the session_id available to the template. See linking to admin from the main site - session parameter

  • So it was a session id. Added a function in my custom plugin to get the session variable. Thank you
    – Rick
    Jul 23, 2014 at 9:09

You need to set the admin session type to "Cookie Only" - this will remove the S=**** part of the URL.

Read up on how to change this setting + implications of changing it here: http://ellislab.com/expressionengine/user-guide/cp/admin/security_settings.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.