0

I've got a page: /events/ that I'd like to pass year and month into: /events/2014/07/ ...and access them ({segment_1}, etc) in the template being used for that page.

But when I go to the url http://host.com/events/2014/07, I get a 404 error because it's apparently looking for a subpage named '2014' with a subpage named '07'.

Regarding posting the code: Why? This doesn't seem to be a code-related issue because I can't even get EE to execute the code in question. The 'events' page is just my standard page template (master/standard). All the pages, for now, use one template. So, /events is using the 'master/standard' template. In it I include 'widgets/calendar' but I want to pass in {segment_2} and {segment_3}. EE won't let me because it doesn't go to the events page. It tries to find a page named "07" under a page named "2014" under the events page. None of this is being handled in the code yet, so I'm not sure what good it would serve to post a bunch of irrelevent EE code.

How do I tell EE to just stop at the events page and use the rest of the url as segments?I know I'm missing some basic EE logic but I'm stumped.

  • 2
    Please post the code from your "events/index" template please. – Anna_MediaGirl Jul 21 '14 at 17:03
  • 1
    Also please post what version of EE you're running, and what add-ons you're running. (I've tried to get a year-display with EE, like you're trying to do, and I had to install Low Yearly Archives plugin. Then...it worked.) – user800 Jul 21 '14 at 17:41
  • How is the /events using the master/standard template? Routes? – Robson Sobral Jul 22 '14 at 1:45
1

Probably you're getting a 404 because the exp:channel:entries tag is trying get all entries of the year 2014 and month 07. If you need to use years, months and days as segments, you gonna need to set dynamic parameter to no.

Take a look at the URL Schematic

| improve this answer | |
0

If you are using the full version of expressionengine, you can use routing to change how your template handles segments. Otherwise, I believe you would need to turn strict url's off in the admin.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.