1

Everything else works. And I can login through the back end. But when I submit the login form I get a blank page and am not logged in.

I replaced my login page with the example code on the Expression Engine Member Management page - http://www.ellislab.com/expressionengine/user-guide/add-ons/member/index.html#login-form-tag but got the same result.

Does anyone have any ideas on what might be the cause, or how I can go about identifying it?

I tried uninstalling various member related addons such as User, Twomile Login Redirect and Authenticate, but that hasn't helped.

1

I had similar issues. It got a bit confusing as session timeouts etc. seem to come in to play, so things I did seemed to work then it stopped working etc. as I experimented with different combinations.

In the end, things I did that solved it:

I changed the front end session type to cookie, and explicitly added the XID hash to all my login forms (actually ALL forms), e.g.

 input type="hidden" name="XID" value="{XID_HASH}" 

Also, and this was important I think, I cleared exp_sessions of old sessions data (will log you out obviously). It would have been easier to work out the issues if I had done this after each change.

And in my config, I changed back from secure cookies only, set my cookie domain, and made sure the cookie gets expired on browser close (this is with focuslab llc so adapt if you're not using that).

+$env_config['cookie_secure']                         = 'n';
+$env_config['cookie_domain']                        = "mydomain.net";
+$env_config['expire_session_on_browser_close']      = 'y';

As far as I can tell, these changes are to do with 2.8.1 and secure forms changes, i.e. secure forms are on by default. But it's all a bit unclear and maybe someone more informed can give a better reason as to the whys of it all - but this got it all working again (both front and back ends)

Hope this gets you going!!

| improve this answer | |
  • Thanks Jeremy. Your suggestions didn't fix it unfortunately. When I did the update to 2.9.0 I neglected to do the cache clearance step. I did it after the update. Hopefully this hasn't throw a spanner into the works. Another odd thing I've noticed that is a bit odd (which may or may not be related) is that in the 'General configuration' I'm unable to set the 'Is system on' setting to 'No'. – Craig Allen Jul 28 '14 at 0:37
  • Have you got a config variable set for the system On thing? It will overrule the CP. I use DevDemon Updater to do all my EE upgrades now, much easier and seems much smoother overall. – Jeremy Daalder Jul 28 '14 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.