0

Two days ago I upgraded a local dev site from 2.6x to 2.9. The local site is running via MAMP Pro, running PHP 5.5.10. I am also using the FocusLab master_config file.

Before upgrading, I ran the server test to make sure things were ok, and they were. The upgrade itself (manual, not using DevDemon updater) went off without errors. I did have a few issues after upgrading, one related to an add-on and another was an error in one of my templates, but I was able to figure them out. Everything seemed to run ok (or so I thought).

The next morning, I was getting an error message try to access the site. "Unable to determine what should be displayed. A default route has not been specified in the routing file."

This happens on the front end or trying to get into the Control Panel. But I can serve up a static file (like robots.txt). I thought it might have something to do with the MAMP Pro install (I had to move the files to another location) so I set up on my Mac Air today. Same exact error. Other local sites still running 2.6x and 2.7x are running ok.

I have also added the following into my config.master file without any luck

$config['uri_protocol'] = 'AUTO';

$config['enable_template_routes'] = 'n';

(I also tried PATH_INFO, QUERY_STRING, REQUEST_URI, ORIG_PATH_INFO for uri_protocol)

Anyone have any suggestions on things to check or try? Yes, downgrading to 2.7x is an option but I thought this might be something known or easy to fix.

3

Check your config folder for integrity. For that specific error, specifically /system/expressionengine/config/routes.php should have ee/index specified as the default_controller. But if that file is incorrect, that's a sign that the other config files may be incorrect as well. If you see it there, check file permissions to make sure the config files are readable.

| improve this answer | |
  • Thanks Derek. It turns out that I was missing routes.php and several other files too. I wondered about this the other night so I replaced the system folder. Not sure if my download was bad or what, but it looks like that took care of it. I appreciate the fast response!! – Todd Jul 29 '14 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.