Has anyone ever come across this error before? I've never seen it.

When a form is submitted, users get the error shown in the screenshot attached.

enter image description here

  • Nit seen this before but is your ISP switching IP's randomly? Commented Jul 31, 2014 at 17:51
  • Could be, as I'm on a dynamic IP but its never happened before. I've used a dynamic IP address for around 12 years. I've submitted forms on this project for nearly 2 years and never seen this error. Developing for EE for nearly 5 years and never seen this error. Very very weird! Commented Jul 31, 2014 at 18:13
  • I'm having exactly this issue and the internet doesn't seem to be very helpful. Did you resolve it?
    – ammykamii
    Commented Jan 22, 2015 at 10:19
  • Nope, no solution yet. Commented Jan 22, 2015 at 10:58

3 Answers 3


Just spitballing here, but some sort of misconfigured proxy is the first thing that jumps out at me.

  • Or perhaps some kind of attempted Man In The Middle attack
    – foamcow
    Commented Jan 23, 2015 at 12:36

OK, I found a quick fix / workaround for this.

What the Forms Module looks to be doing is checking the IP address of where the form data is coming from, to the IP address that the form thinks it is.


And at around line 82 you should see:

    // Same IP?
    if ($this->EE->forms->data['ip_address'] != $this->EE->forms->ip_address)
        return $this->return_error('missing_data', $this->EE->lang->line('form:error:missing_data') . '(DIFFERENT_IP)');

I commented out these lines and it's working again. Why it started to do this I've no idea, the External IP has not changed, I've cleared the cache, I've rebooted the server, still no luck.

FINAL EDIT : We have a load balancing server. The IP address that the web server sees for that server is obviously different to the external IP address the visitor comes in on. Two different IP addresses. Why it just started happening now is still a mystery.

  • this worked for me - weird but thanks! Commented Aug 18, 2015 at 15:36

Thanks for that , same thing happened to me when I turned on cloudflare cdn for my site. I did it via Cname so it changed my visible ip and caused the problem with all of my forms. Commenting those lines sorted it out for me. I am going to submit a ticket to devdemon to see if they have a more structured solution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.