I'm not sure what is happening. I have used the Simple Search successfully before but am not having any luck with it and EE 2.8.1. Hopefully someone can assist me with this as I'm sure I'm missing something simple :)

Snippet containing the simple search tag:

{exp:search:simple_form channel="blog" result_page="blog/search" search_in="everywhere" status="open" where="all" show_expired="yes" show_future_entries="yes"}
<input type="text" id="keywords" name="keywords" placeholder="Enter your search" class="pull-left">
<input type="submit" id="submit">

Here's my /blog/search template which was taken directly from the documentation:

<table border="0" cellpadding="6" cellspacing="1" width="100%">

{exp:search:search_results switch="resultRowOne|resultRowTwo"}

    <tr class="{switch}">
        <td width="30%" valign="top"><b><a href="{auto_path}">{title}</a></b></td>
        <td width="30%" valign="top">{excerpt}</td>
        <td width="10%" valign="top"><a href="{member_path='member/index'}">{author}</a></td>
        <td width="10%" valign="top">{entry_date format="%m/%d/%y"}</td>
        <td width="10%" valign="top">{comment_total}</td>
        <td width="10%" valign="top">{recent_comment_date format="%m/%d/%y"}</td>

    {if count == total_results}

        <p>Page {current_page} of {total_pages} pages {pagination_links}</p>



I'm attempting to search within a GRID field and have my Field Marked as Searchable as well as the column I want to search in. I have several Blog Entries setup with various content. Most of them have the word "Testing" in them yet when I search for that word I get no results.

What else could I be missing?


What's also weird is that sometimes the "Error" page (which pulls in the User Message Template) has the Heading missing at times like so. I doubt it's related but still strange!

enter image description here

  • Have you tried adding a no results page? Aug 4, 2014 at 20:14
  • I have, but that doesn't seem to matter either. Aug 4, 2014 at 22:10
  • Is the content "testing" in one of the searchable fields in an entry in the blog channel with a status of open? Aug 11, 2014 at 14:42
  • Yes the page in question is here: placewise.uldev.co/blog I can't search titles or Grid Fields although the grid field type and each comment is set to searchable. Aug 11, 2014 at 14:47
  • 1
    I'd be happy to take a look and troubleshoot directly for you if you want to put in a ticket with your log in info. Aug 16, 2014 at 20:48

3 Answers 3


Looks like this was a FREEBIE issue. I set "search" to always parse and POOF! Thanks to Kevin @ Ellis Lab for the help on this one!


Try replacing search_in="everywhere" with search_in="entries" in the exp:search:simple_form tag. I remember having problems with this with EE 2.8.1. Also try removing where="all".

I hope this helps


We had the same issue with our search form and it ended up being we had stickies turned off in our server, so our session was pointing to another server when we hit submit. Thus shooting this type of error because it was looking for something that didn't exist in that server. -- I hope this helps.

  • Can you edit your answer to be more clear about this part... "we had stickies turned off in our server"?
    – Anna_MediaGirl
    Sep 23, 2014 at 3:39
  • sure Anna, say you have 2 backend servers, www1.example.com and www2.example.com. You’d add the following to your backend vhost configuation :
    – javi
    Sep 23, 2014 at 13:38
  • RewriteEngine On RewriteRule .* – [CO=BALANCEID:balancer.www1:.example.com][/code]then do the same for www2, obviously changing the cookie val to reflect this. You then need to tell your frontend proxy that it should look for this cookie, and which server each "route" refers to :
    – javi
    Sep 23, 2014 at 13:43
  • ProxyPass / balancer://cluster/ lbmethod=byrequests stickysession=BALANCEID ProxyPassReverse / balancer://cluster/ <Proxy balancer://cluster> BalancerMember www1.example.com route=www1 BalancerMember www2.example.com route=www2 </Proxy>
    – javi
    Sep 23, 2014 at 13:45
  • 1
    @javi please update your answer, rather than adding comments. Sep 23, 2014 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.