0

I'm trying to add a CAPTCHA to a Freeform (free version) form.

The form is a callback request form that features in the header of the site, so is visible on every page and is not linked to a specific channel.

I've got the CAPTCHA to show up but the form can be submitted with the CAPTCHA text field left blank.

Anyone know a good way of using a CAPTCHA with Solspace's Freeform in this way?

0

In the documentation there is a parameter to make sure the captcha is required

This assumes you are using the freeform captcha not the default ExpressionEngine one.

If you have done these things already, please edit your question to include your code.

  • Thanks for your thoughts, I'm actually using the free version of Freeform and it appears these features are limited to the paid version? – Tom Perkins Aug 7 '14 at 9:07
  • That's not correct, you can get the captcha to work with the free version too :) Be default captchas are disabled for logged in members. Go to Admin > Security and Privacy > CAPTCHA Preferences and check the "Require CAPTCHA with logged-in members?". i typically test in Google Incognito mode too then you can see if that's your issue too. – Mark Busnelli Jr Nov 4 '14 at 16:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.