0

We migrated our site to a new server and upgraded from EE 2.5.2 to 2.9. Playa and other add-ons were already installed on the site when I inherited it. I updated Playa according to their instructions but I ran into a bunch of problems. First, while Fieldtypes displayed the new version, 4.5 when I went to Modules it was still saying 4.3.3. No matter what I did I couldn't get it to update in both places. Eventually I figured out it was a problem with permissions on the server so I contacted our host and got that resolved, uploaded the files again but that still didn't help. Ultimately I had to uninstall the plugin using the uninstall option on the backend, then I reinstalled it and that finally worked: I saw the current version 4.5 in both places on the backend.

Now the only problem is I got a bunch of PHP errors on the front end whenever I tried to display an article that used the Playa relationships field.

    Error Number: 1054

Unknown column 'rel.parent_is_draft' in 'where clause'

SELECT DISTINCT(rel.child_entry_id) AS entry_id FROM exp_playa_relationships rel WHERE rel.parent_entry_id = 1 AND rel.parent_is_draft = 0 ORDER BY rel.rel_order

Filename: /third_party/playa/mod.playa.php

Line Number: 739

It's identical to the problem mentioned in this thread. The solution there was that the Playa update didn't complete properly. I uploaded the new files several times. And I even reinstalled the plugin and still got the error. The only way I could get the site to function was to comment out several lines of code in that file. Now the site works and no more PHP errors but neither does Playa work and none of our Related Articles are displaying.

Can anyone help? Thanks in advance. :)

1
  • Can you post the result of the following MySQL query: DESCRIBE exp_playa_relationships
    – AllInOne
    Aug 5 '14 at 18:29
0

Here's the create table statement that would get you to what I have installed on my version of Playa 4.5

CREATE TABLE `exp_playa_relationships` (
  `rel_id` int(10) unsigned NOT NULL auto_increment,
  `parent_entry_id` int(10) unsigned default NULL,
  `parent_field_id` int(6) unsigned default NULL,
  `parent_col_id` int(6) unsigned default NULL,
  `parent_row_id` int(10) unsigned default NULL,
  `parent_var_id` int(6) unsigned default NULL,
  `parent_is_draft` int(1) unsigned NOT NULL default '0',
  `child_entry_id` int(10) unsigned default NULL,
  `rel_order` int(4) unsigned default NULL,
  PRIMARY KEY  (`rel_id`),
  KEY `parent_entry_id` (`parent_entry_id`),
  KEY `parent_field_id` (`parent_field_id`),
  KEY `parent_col_id` (`parent_col_id`),
  KEY `parent_row_id` (`parent_row_id`),
  KEY `parent_var_id` (`parent_var_id`),
  KEY `child_entry_id` (`child_entry_id`)
)

From your error it appears you are missing the column exp_playa_relationships, possibly others. Compare to your current structure and fill in as necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.